Contents

**Introduction** ................................................................................................. 5
  Overview ........................................................................................................ 5
  Intended Audience ....................................................................................... 5
  Icons ............................................................................................................... 5
  Additional Resources .................................................................................. 5
    Related Publications ................................................................................ 6
    Online Documentation ............................................................................. 6
  Customer Support ....................................................................................... 6
    Compuware Support Center Website ....................................................... 6
    Contacting Customer Solutions ............................................................ 6
    Corporate Website ................................................................................... 7

**Overview** .................................................................................................... 9
  Topaz Workbench Overview ..................................................................... 9
  Topaz Workbench Features ...................................................................... 9
  Topaz Workbench Architecture .............................................................. 11
  Topaz Workbench Command Line Interface Overview .................................
    SonarQube Workflow .......................................................................... 12
    Topaz for Total Test Workflow .......................................................... 12
    Topaz Workbench CLI Architecture .................................................... 12

**Planning** ....................................................................................................... 13
  Process .......................................................................................................... 13
  Milestones and Roles .................................................................................. 13

**Milestone 1: Prerequisites** ........................................................................ 15
  Requirements .............................................................................................. 15
    Task 1.1 Verify System Requirements .................................................. 15
    Task 1.2 Verify Compuware Companion Product Requirements .......... 16

**Milestone 2: Install Topaz Workbench** ..................................................... 19
  Installation Procedure ............................................................................... 19
    Task 2.1 Determine Topaz Workbench Features to Install ...................... 19
    Task 2.2 Install Topaz Workbench ......................................................... 19
    Task 2.3 Install Topaz Workbench CLI .................................................. 20

**Milestone 3: Upgrade Topaz Workbench** .................................................. 23
  Upgrade Process .......................................................................................... 23
    Changes Required Upon Upgrading ...................................................... 24
    Task 3.1 Upgrade Topaz Workbench ....................................................... 25
Introduction

This manual provides information about how to install, customize, and maintain Topaz Workbench.

Overview

This document contains instructions intended for the Topaz Workbench distributed systems installer for installing, configuring, deploying, and troubleshooting Topaz Workbench to multiple end users.

Intended Audience

This manual is intended for Topaz Workbench installers and system programmers.

Icons

The alerts found in this guide include:

- A note or tip providing additional information.
- Information important to remember.
- Roles involved in the installation.
- Technical information to consider.
- Caution. Failure to follow these instructions can cause problems.
- Fast Forward. Hyperlinked image to advance to the next step when the current step can be skipped.

Additional Resources

Refer to these other sources of information on Topaz Workbench.
Related Publications

An RFN order e-mail also includes a copy of the *Compuware Installer Mainframe Products SMP/E Installation Guide*, which should be used to perform the installation of Compuware mainframe products. Preparation for installation and post-installation configuration should be done in accordance to this guide.

- *Topaz Workbench Release Notes*
- *Topaz Workbench Messages and Codes*
- *Topaz Workbench Installation and Configuration*

Further configuration information for integrations with Compuware mainframe products is found in the installation and configuration guides associated with those products. See the Table 1. Install additional Compuware companion products for use with Topaz Workbench for more information.

Online Documentation

The Topaz Workbench product installation package does not include the product documentation. Access the Topaz Workbench documentation from the Compuware Support Center web site at [https://go.compuware.com](https://go.compuware.com) in the following electronic formats:

- Release Notes in HTML format.
- Product manuals in PDF and HTML format.

The product documentation is available for viewing or downloading:

- View HTML files with any standard web browser.

Customer Support

Compuware provides a variety of support resources to make it easy for you to find the information you need.

Compuware Support Center Website

You can access online information for Compuware products via the Compuware Support Center website at [https://go.compuware.com](https://go.compuware.com).

Compuware Support Center provides access to critical information about your Compuware products. You can review frequently asked questions, read or download documentation, access product fixes, or e-mail your questions or comments. The first time you access Compuware Support Center, you are required to register and obtain a password. Registration is free.

Contacting Customer Solutions

Phone

- USA and Canada: 1-800-538-7822 or 1-313-227-5444.
- All other countries: Contact your local Compuware office. Contact information is available at [https://go.compuware.com](https://go.compuware.com).
Web

You can report issues via the Quick Link Create & View Support Cases on the Compuware Support Center home page.

Please report all high-priority issues by telephone.

Mail

Compuware Customer Solutions
Compuware Corporation
One Campus Martius
Detroit, MI 48226-5099

Corporate Website

To access Compuware’s site on the Web, go to http://www.compuware.com.

The Compuware site provides a variety of product and support information.
Overview

The Topaz Workbench Installation guide contains instructions for Topaz Workbench distributed systems installers to assist in installing, configuring, and deploying Topaz Workbench to multiple end users. These instructions include validating the product is installed and configured correctly prior to its deployment.

Topaz Workbench Overview

Topaz Workbench provides an Eclipse-based IDE to streamline mainframe application development with System z software. Its intuitive interface provides the essentials of modern mainframe application development, testing, and maintenance.

Topaz Workbench also supports a seamless integration with SonarSource’s SonarLint COBOL plug-in. Developers can now get on-the-fly feedback on code quality and adherence to standards as they edit mainframe source code. In addition, Topaz Workbench now works with Jenkins for Continuous Integration. This integration enables organizations to easily publish COBOL code metrics into SonarSource’s SonarQube—a popular dashboard for tracking quality metrics and technical debt. Development and QA managers can more easily keep projects on schedule and address shortfalls in quality or technical standards.

Topaz Workbench Features

Topaz Workbench is comprised of the following features that are available as install options.

Host Explorer

Host Explorer provides mainframe application developers a distributed platform alternative to a 3270 session by allowing them to stay inside the GUI workstation environment. The Host Explorer feature is required.

Topaz 3270 Emulator

The Topaz 3270 Emulator is an embedded emulator within Topaz Workbench to accommodate one-off 3270 interactions without leaving Topaz. It can be used, for example, to run REXX/CLIST utilities within ISPF or to access CICS or IMS transactions to initiate debugging sessions. SSL connections are supported.

Topaz Editors

New Topaz editors for COBOL, PL/I, C, Assembler, JCL, and REXX have replaced the Compuware Editor. An improved outline view and program templates for COBOL and PL/I are provided. The language editors are used during Xpediter/Eclipse debug sessions and with Topaz Program Analysis for COBOL and PL/I. SonarLint support is also included, plus copybook support, code assist, compare, and search capabilities. The COBOL editor offers revision tags, a number command, hover, and go to declarations. Hyperlinking of datasets in the JCL editor along with Submit/Submit Compile.

Topaz for Total Test

Topaz for Total Test lets users build repeatable unit and functional tests for batch, CICS, DB2, and IMS COBOL programs utilizing Xpediter debug sessions. A method is provided to stub out parts of the program and data file calls to allow tests to run more isolated with fewer system requirements. Code Coverage can also be enabled. Test case execution can then be automated and added as part of a
continuous integration and build process. A Command Line Interface (CLI) and Jenkins plugin are available for streamlining the execution process.

**Topaz for Program Analysis**

Topaz for Program Analysis provides an instant static visual summary of what a developer needs to know about a program or a dynamic visualization via Runtime Visualizer for a clear and accurate “snapshot” of a program’s real behavior in either production or test environments under runtime conditions.

**Topaz for Enterprise Data**

Topaz for Enterprise Data provides a single interface to manage both mainframe and non-mainframe data in a common, intuitive manner, helping developers and data architects to quickly and easily understand data and data relationships. It includes capabilities to edit, compare, search/update, extract/load, convert, and visualize data. It also includes the ability to edit SQL, define and apply data privacy rules to mask data.

**Topaz Connect**

Topaz Connect provides developers with CA Endevor functions to browse listings, browse and retrieve Endevor elements, and work in project mode by retrieving groups of elements for editing as an Endevor package.

**Xpediter/Eclipse**

Xpediter/Eclipse provides mainframe debugging by interfacing with Xpediter/TSO and Xpediter/IMS or Xpediter/CICS mainframe products.

**ISPW**

The ISPW Eclipse feature is a modernized GUI for Compuware ISPW, a comprehensive software change management (SCM) mainframe product. ISPW also provides both mainframe and distributed cross-platform application deployment and cooperates with local versioning tools.

**Code Coverage/Eclipse**

Code Coverage/Eclipse is the modernized GUI for Compuware Xpediter/Code Coverage, which provides the ability to create reports detailing testing efficiency and risk metrics for mainframe COBOL, PL/I, and High Level Assembler programs.

**Abend-AID**

Provides integrations with Abend-AID as well as an interface to display Abend-AID in a web browser.

**iStrobe**

Provides integrations with iStrobe as well as an interface to display iStrobe in a web browser.

**Fault Analytics**

Provides an interface to Abend-AID Fault Analytics in a web browser.

**Topaz Workbench SDK**

The Topaz Workbench SDK includes the Topaz Workbench Host Services API that provides users with methods to programmatically access and perform dataset and JES operations, as well as launch and communicate with z/OS programs.
**Topaz Workbench Architecture**

Topaz Workbench operates in a three-platform architecture. Each platform provides services and integrations to Compuware companion products.

**Desktop Platform**

Topaz Workbench is an Eclipse-based IDE that is installed on Microsoft Windows. Topaz Workbench can also be installed as features into an Eclipse IDE.

**Web Platform**

Topaz Workbench integrates with the following Compuware web products:

- Compuware Enterprise Services (CES). CES provides lease-based licensing for Topaz features as well as automatic synchronization of Topaz configurations among end users.
- Abend-AID and iStrobe.

Compuware Enterprise Services (CES) is required to manage the lease-based licensing for the following Topaz Workbench features: Topaz for Program Analysis, Topaz for Enterprise Data, and Topaz for Total Test. Otherwise, CES is optional. For more information on licensing, see Appendix, Topaz Workbench Licensing.

**Mainframe Platform**

Topaz Workbench communicates with Compuware mainframe products via the Host Communications Interface (HCI) component of Enterprise Common Components (ECC). Topaz Workbench base features are licensed via License Management System (LMS). See Appendix, Topaz Workbench Licensing for more information.
Topaz Workbench Command Line Interface Overview

The Topaz Workbench Command Line Interface (CLI) is a separate installation from Topaz Workbench and can be installed on Windows or Linux. Topaz Workbench CLI is an application that provides the following functionality:

- Facilitates integration with SonarQube by downloading source in conjunction with the Jenkins plugin, Compuware Source Code Download for Endevor, PDS, and ISPW Plugin.
- Orchestrates running Topaz for Total Test unit tests in conjunction with the Jenkins plugin, Compuware for Total Test Plugin, Compuware for Total Test Plugin.

SonarQube Workflow

1. Source is committed to PDS, Endevor, or ISPW. Topaz Workbench can, optionally, be used to commit source.
2. The Jenkins plugin, Compuware Source Code Download for Endevor, PDS, and ISPW Plugin calls the Topaz Workbench CLI to download source from PDS, Endevor, or ISPW.
3. SonarQube analyzes the downloaded source.

Topaz for Total Test Workflow

1. Unit tests are committed to source control or copied to a central file system.
2. The Jenkins plugin, Compuware for Total Test Plugin, calls the Topaz Workbench CLI to run unit tests on the mainframe.

Topaz Workbench CLI Architecture
Planning

Process

1. Order Topaz Workbench (and companion products), including the latest maintenance, through Compuware’s Product Ordering web page or by contacting your Compuware Representative.

2. Ensure you satisfy system requirements and any specified prerequisites.

3. Install or upgrade a single instance of Topaz Workbench.


5. Deploy Topaz Workbench to end users.

6. Review/follow the remainder of these instructions as they apply to your site’s specific requirements.

Milestones and Roles

Installation, configuration, verification, and deployment are accomplished in the milestones listed in Table 1. Within each milestone, the role or skill set required to perform each milestone and/or task is identified.

Table 1. Milestones and Roles

<table>
<thead>
<tr>
<th>Milestone</th>
<th>Compuware Product Installer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Milestone 1: Prerequisites</td>
<td>Various installers&lt;sup&gt;a&lt;/sup&gt;</td>
</tr>
<tr>
<td>Milestone 2: Install Topaz Workbench</td>
<td>Topaz Workbench Installer</td>
</tr>
<tr>
<td>Milestone 3: Upgrade Topaz Workbench</td>
<td>Topaz Workbench Installer</td>
</tr>
<tr>
<td>Milestone 4: Configure and Verify Topaz Workbench</td>
<td>Topaz Workbench Installer</td>
</tr>
<tr>
<td>Milestone 5: Deploy Topaz Workbench</td>
<td>Topaz Workbench Installer</td>
</tr>
<tr>
<td></td>
<td>CES Administrator</td>
</tr>
</tbody>
</table>

<sup>a</sup> See the milestone tasks to determine the Compuware companion product installers that will be involved.
Milestone 1: Prerequisites

For full functionality with your Compuware mainframe products, ensure the following prerequisites are satisfied before installing or upgrading Topaz Workbench.

Requirements

Task 1.1 Verify System Requirements

Hardware Platforms for Distributed Systems
- Microsoft Windows x86, x64
- Processor: 2 GHz minimum
- Hard Disk: 700 MB minimum
- Memory: 2 GB minimum

Software Requirements for Topaz Workbench
- Microsoft Windows 7, 8.1 Update (KB 2919355), 10

Corequisite Software for Topaz Workbench
- Eclipse Photon 4.8
- Oracle Java SE 8 (for Eclipse IDE only)
- Microsoft Internet Explorer 11 for the supported Windows releases
- Microsoft Visio 2010 with Service Pack 2 and Compatibility Pack, 2013 (if exporting from Data Visualizer)
- SonarLint 3.1, 3.2, 3.3.1, 3.4, 4.1, 4.2 and access to a SonarQube installation that contains the COBOL plugins with a valid license for COBOL (if using SonarLint to analyze COBOL code within mainframe projects).
- Compuware Enterprise Common Components (ECC) PTF CXS905A must be applied, if mainframe data will be accessed. This PTF enables CES with access to File-AID licenses.

Software Requirements for Topaz Workbench Command Line Interface (CLI)
- Oracle Java SE 8
- Microsoft Windows 7, 8.1 Update (KB 2919355), 10, server 2012
- Redhat Linux or Ubuntu

Topaz for Total Test Supported IBM Product Versions
- IBM DB2 for z/OS V11.1, 12.1
- IBM IMS Transaction and Database Servers V14.1, 15.1
- IBM Enterprise COBOL for z/OS V4.2, 5.1, 5.2, 6.1, 6.2, 6.3
- IBM Enterprise PL/I for z/OS V5.3
- IBM z/OS V2.4

Dropping Support

The LMS Central License Facility (CLF) is no longer supported, as of January 1, 2019.
Task 1.2 Verify Compuware Companion Product Requirements

Topaz Workbench requires that Compuware products be configured specifically for Topaz Workbench. Follow these instructions to ensure that Compuware companion products are installed and configured to enable Topaz Workbench.

Roles involved: Various Compuware companion product installers will be involved based on the Topaz Workbench features to install.

Task 1.2.1 Ensure ECC is configured for use with Topaz Workbench

Enterprise Common Components (ECC) is a common component that provides services such as product licensing and mainframe connectivity.

Role involved: ECC Installer

1. Ensure that ECC version 17.02 is installed with the latest cumulative maintenance.
2. Ensure that ECC is configured for Topaz Workbench by following the configuration instructions in the Enterprise Common Components Installation and Configuration Guide.

Task 1.2.2 Ensure CES is configured for use with Topaz Workbench

CES is required for licensing the following Topaz Workbench features: Topaz for Program Analysis, Topaz for Enterprise Data, and Topaz for Total Test. Otherwise, CES is optional.

Role involved: CES Installer

1. Ensure a minimum of Compuware Enterprise Services (CES) version 18.02 is installed with current cumulative maintenance so you can use valuable features such as shared Topaz Workbench configurations and automatic updates using Update Center. It is recommended that you install CES 19.06 or higher to utilize current features.
2. Ensure that CES is configured for Topaz Workbench. Follow the configuration instructions in the Compuware Web Products Installation Guide.
Task 1.2.3 Ensure additional Compuware companion products are installed and configured for use with Topaz Workbench

<table>
<thead>
<tr>
<th>Topaz Workbench Feature</th>
<th>Required Companion Product</th>
<th>Role</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Topaz for Total Test</td>
<td>Enterprise Common Components (ECC) version 17.02 or higher must be installed with the latest cumulative maintenance.</td>
<td>ECC Installer</td>
<td>See the installation instructions in the Enterprise Common Components Installation and Configuration Guide.</td>
</tr>
<tr>
<td></td>
<td>Xpediter/TSO and IMS release 17.02 with cumulative maintenance</td>
<td>Xpediter/TSO and IMS Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Xpediter/TSO and Xpediter/IMS Installation Guide.</td>
</tr>
<tr>
<td></td>
<td>Xpediter/CICS release 17.02 with cumulative maintenance</td>
<td>Xpediter/CICS Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Xpediter/CICS Installation Guide.</td>
</tr>
<tr>
<td></td>
<td>Xpediter/Code Coverage release 17.02 with cumulative maintenance to enable code coverage collection when running unit tests</td>
<td>Xpediter/Code Coverage Installer</td>
<td>See the Xpediter/Code Coverage Installation and Configuration Guide.</td>
</tr>
</tbody>
</table>
| Topaz for Program Analysis | To enable the Runtime Visualizer feature, the following are required:  
- For batch programs, Xpediter/TSO and /IMS 17.02 or higher with cumulative maintenance  
- For CICS programs, Xpediter/CICS 17.02 or higher with cumulative maintenance  
- For DB2 data, Abend-AID 17.02 or higher with the DB2 option and cumulative maintenance | Xpediter/TSO and IMS Installer | See the section about configuring Topaz Workbench integration in the Xpediter/TSO and Xpediter/IMS Installation Guide.  
See the section about configuring Topaz Workbench integration in the Xpediter/CICS Installation Guide.  
See the section about configuring Topaz Workbench integration in the Abend-AID Installation and Configuration Guide. |
| Topaz for Enterprise Data | File-AID release 17.02 or higher with cumulative maintenance. Topaz for Enterprise Data media containing:  
- File-AID Services  
- File-AID Rules Engine  
- File-AID/EX  
- File-AID Execution Servers | File-AID Installer | See the “Prepare for Topaz Workbench Integration” milestone in the File-AID Installation and Configuration Guide. |
<p>| File-AID/Eclipse       | File-AID 17.02 or higher with cumulative maintenance | File-AID Installer | See the “Prepare for Topaz Workbench Integration” milestone in the File-AID Installation and Configuration Guide. |</p>
<table>
<thead>
<tr>
<th>Topaz Workbench Feature</th>
<th>Required Companion Product</th>
<th>Role</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Xpediter/Eclipse</td>
<td>For batch debugging, Xpediter/TSO and IMS 17.02 or higher with cumulative maintenance.</td>
<td>Xpediter/TSO and IMS Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Xpediter/TSO and Xpediter/IMS Installation Guide.</td>
</tr>
<tr>
<td></td>
<td>For CICS debugging, Xpediter/CICS 17.02 or higher with cumulative maintenance.</td>
<td>Xpediter/CICS Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Xpediter/CICS Installation Guide.</td>
</tr>
<tr>
<td>ISPW</td>
<td>ISPW 17.02 or higher with cumulative maintenance</td>
<td>ISPW Installer</td>
<td>See the section about configuring Topaz Workbench integration in the ISPW Installation and Configuration Guide chapter entitled “Install Base Software”, “Step 4. Define Communications Setup” to configure the connections between Topaz Workbench and ISPW’s CT service. For Topaz Workbench 18.2.1 and above, also see the chapter entitled “Configure Topaz Workbench Integration”.</td>
</tr>
<tr>
<td>Code Coverage/Eclipse</td>
<td>Xpediter/Code Coverage 3.01 or higher with cumulative maintenance</td>
<td>ECC Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Enterprise Common Components Installation and Configuration Guide.</td>
</tr>
<tr>
<td>Hiperstation/Eclipse</td>
<td>Hiperstation 17.02 or higher with cumulative maintenance</td>
<td>Hiperstation Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Enterprise Common Components Installation and Configuration Guide.</td>
</tr>
<tr>
<td>Abend-AID</td>
<td>Abend-AID 17.02 or higher with cumulative maintenance</td>
<td>Abend-AID Installer</td>
<td>See the section about configuring Topaz Workbench integration in the Abend-AID Installation and Customization Guide.</td>
</tr>
<tr>
<td>iStrobe</td>
<td>iStrobe 18.02.03 or higher with cumulative maintenance</td>
<td>Compuware Web Products Installer</td>
<td>See the section “Configuring Compuware Enterprise Services” in the Compuware Web Products Installation Guide.</td>
</tr>
<tr>
<td>Fault Analytics</td>
<td>Abend-AID Fault Analytics 17.02 or higher with cumulative maintenance</td>
<td>Compuware Web Products Installer</td>
<td>See the section “Configuring Compuware Enterprise Services” in the Compuware Web Products Installation Guide.</td>
</tr>
</tbody>
</table>
Milestone 2: Install Topaz Workbench

Two types of installations are available on the Topaz Workbench media: Topaz Workbench and Topaz Workbench Command Line Interface (CLI). Installation instructions are provided for each.

Role involved: Topaz Workbench Installer

Installation Procedure

Task 2.1 Determine Topaz Workbench Features to Install

As outlined in the Overview, Topaz Workbench is composed of a variety of features. Determine which features you want to have installed, as you will be prompted during the installation to select them.

You can add or remove features after Topaz Workbench is installed (see Appendix, Adding and Removing Topaz Workbench Features for more information).

Task 2.2 Install Topaz Workbench

Instructions are provided here for installing a single instance of Topaz Workbench with the following options:

- As a client application.
- As features into an Eclipse IDE.

Instructions for installing and deploying to multiple end users is covered in Task 5.2 Deploy Topaz Workbench to End Users.

Task 2.2.1 Install Topaz Workbench Client

To install Topaz Workbench as a standalone client

1. Run the setup.exe file located in the root directory of the Topaz Workbench media image. This launches the Topaz Workbench media browser.

   If you double-click or open the setup.exe and it does not execute, select the Run As Administrator option when launching setup.exe.

2. In the media browser, click Install Topaz Workbench to launch the install wizard.
3. Once the install wizard is running, follow the on-screen instructions.
4. Ensure that only the features you want to install are selected.

Compuware recommends that Topaz Workbench be installed to a location where users have update privileges, such as the user’s home directory (for example, C:\Users\JaneDoe\Compuware\Topaz), because the Windows Program Files folder is often restricted, and may prevent users from updating Eclipse-based software.

5. Optionally, specify the Compuware Enterprise Services (CES) URL for access to Customization Administration.

6. Click Next and follow the instructions to complete the install wizard.

**Task 2.2.2 Install Topaz Workbench Features into an Eclipse IDE**

When installing the **ISPW/Eclipse** or **Topaz for Enterprise Data** features into **Eclipse-based IDEs**, the following **Software Sites** must also be included and enabled.

- **For Photon**
  
  http://download.eclipse.org/releases/photon
  
  http://download.eclipse.org/eclipse/updates/4.8

If Topaz Workbench Datatools will be used, the **Compuware DB2 for z/OS using Topaz (base)** feature must also be selected during install. This plugin is optional and not required if the native Eclipse datatools plugins will be used.

To install Topaz Workbench features into an existing installation of an Eclipse IDE:

1. Download the p2 repository zip file via one of the following methods:
   
   - From the **Topaz Workbench p2 repository** link in the Topaz Workbench product order email.
   
   - From the **Products > Topaz Workbench** page under **Downloads** on the Compuware Support Center web site.

2. Unzip (extract) the downloaded file to a local directory.

3. Within the IDE under **Help**, select **Install New Software...** to add a Software Site.

   a. Click **Add... > Local** to browse to the unzipped p2 repository folder (software site), named `topazWorkbench_n.n.n.n`, where `n` represents the release, version, maintenance level and build number.

   b. The **Location** field will now reference the p2 repository. Provide a name in the **Name** field. Click **OK**.

4. Ensure the **Contact all update sites...** checkbox is selected.

5. Click **Next** and follow the install wizard instructions to completion, selecting the desired feature(s) to install.

**Task 2.3 Install Topaz Workbench CLI**

Topaz Workbench CLI is required for Topaz for Total Test and SonarQube integration.

**Task 2.3.1 Install Topaz Workbench CLI on Windows**

1. Ensure that Oracle Java SE 8 64-bit or higher is installed on the host machine.
2. Run the setup.exe file located in the root directory of the Topaz Workbench installation media.

If you double-click or open the setup.exe and it does not execute, select the Run As Administrator option when launching setup.exe.

3. In the media browser, select the CLI tab.
4. Click Install Topaz Workbench CLI on Windows.
5. Once the install wizard is running, follow the on-screen instructions.

If you choose to install to a folder of an existing Topaz Workbench CLI installation, you will be prompted to uninstall the existing Topaz Workbench CLI prior to beginning the new installation.

Task 2.3.2 Install Topaz Workbench CLI on Linux

1. Ensure that Oracle Java SE 8 64-bit or higher is installed on the host machine.
2. Insert the media or FTP the contents of Disk 1\cpwr\TopazCLI\Linux to the Linux machine.
3. Navigate to Disk 1\cpwr\TopazCLI\Linux\Disk1\InstData\NoVM.
4. Run install.bin. The Introduction pane appears.
5. Read the Introduction and then press Enter. The License Agreement pane appears.
6. Read the License Agreement and then enter Y to the Do you accept the terms of the License Agreement? prompt. The Choose Install Folder pane appears.
7. Enter an absolute path to the desired installation location or press Enter to accept the default location.
8. At the confirmation prompt:
   a. Enter Y if the default path is acceptable and press Enter. The installation begins.
   b. Enter N and press Enter if the path needs to be changed.
9. When the installation is complete the Install Complete pane appears.
10. Press Enter to exit the installer.
Milestone 3: Upgrade Topaz Workbench

Role involved: Topaz Workbench Installer

Upgrade Process

This milestone provides instructions for upgrading a single user instance of Topaz Workbench from a previous release. Instructions for deploying new releases of Topaz Workbench to multiple end users is covered in Deploy Topaz Workbench.

There are two methods for upgrading an existing installation of Topaz Workbench:

- **Update Wizard**: Topaz Workbench, built on Eclipse technology, offers an Update Wizard that allows users to update Topaz Workbench features of the current installation. Any new features available from the upgrade release will still need to be installed using the procedure in Appendix, “Adding and Removing Topaz Workbench Features”

- **Reinstall**: Reinstall by either uninstalling and installing Topaz Workbench or by installing over an existing installation.

Topaz Workbench has undergone some structural changes that prohibit specific upgrade scenarios from allowing an upgrade via the Update Wizard. These are noted below.

Table 1. Upgrading Topaz Workbench

<table>
<thead>
<tr>
<th>Current Release</th>
<th>New Release</th>
<th>Supported Upgrade Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Topaz Workbench 16.3.x or lower</td>
<td>Topaz Workbench 17.2.x or higher</td>
<td>Reinstall only</td>
</tr>
<tr>
<td>Topaz Workbench 17.2.x</td>
<td>Topaz Workbench 18.2.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 18.2.x</td>
<td>Topaz Workbench 18.3.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 18.3.x</td>
<td>Topaz Workbench 19.1.x</td>
<td>Reinstall only</td>
</tr>
<tr>
<td>Topaz Workbench 19.1.x</td>
<td>Topaz Workbench 19.2.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 19.2.x</td>
<td>Topaz Workbench 19.3.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 19.3.x</td>
<td>Topaz Workbench 19.4.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 19.4.x</td>
<td>Topaz Workbench 19.5.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 19.5.x</td>
<td>Topaz Workbench 19.6.x</td>
<td>Update Wizard or Reinstall</td>
</tr>
<tr>
<td>Topaz Workbench 19.6.x</td>
<td>Topaz Workbench 20.1.x</td>
<td>Reinstall only</td>
</tr>
</tbody>
</table>
Changes Required Upon Upgrading

The following is a history of changes that require action to ensure that Topaz Workbench functions properly upon upgrading.

Table 2. Feature releases

<table>
<thead>
<tr>
<th>Release Introduced</th>
<th>Feature</th>
<th>Change</th>
<th>Action Required</th>
</tr>
</thead>
</table>
| 18.2.1            | ISPW/Eclipse                 | ISPW/Eclipse connection from Topaz Workbench to ISPW mainframe uses HCI for a consistent login experience. | • New configuration options were added to ECC 17.02 and are required for accessing ISPW within Topaz Workbench. An ECC administrator must follow the instructions for Topaz Workbench integration in the Enterprise Common Components Installation and Configuration Guide.  
• Configuration options were added to the ISPW mainframe product to enable this feature. An ISPW mainframe administrator must follow the instructions for Topaz Workbench integration in the ISPW Installation and Configuration Guide.  
• Users who have used the ISPW/Eclipse feature in Topaz Workbench prior to release 18.2.1 will need to update their connection configuration. For instructions, see Task 3.3 Update the ISPW Connection Preference. |
| 18.2.3            | Host Explorer                | Smartcard and Passticket authentication support was added to the Host Explorer feature. | In the rare case that the Smartcard or Passticket authentication features were installed prior to 18.2.3, follow these instructions.  
If you are an end user performing an upgrade, uninstall the following features before upgrading.  
• Compuware Topaz Workbench PassTicket Login Feature  
• Compuware Host Services X.509 Certificates Feature  
See Task C.2 Remove Individual Topaz Workbench Features for instructions on removing features.  
If you are a Topaz Workbench installer who will be deploying the upgrade to end users, there is no action to take besides following Deploy Topaz Workbench. |
| 19.3.2            | Compuware DB2 for z/OS using Topaz | Plug-in install into Eclipse-based IDEs of previous Topaz Workbench releases installed the Datatools plug-ins along with the File-AID/Eclipse feature. This is now a separate feature. | During plug-in install, expand the Compuware DB2 for z/OS using Topaz feature and select only the (base) component |
Table 2. Feature releases (Continued)

<table>
<thead>
<tr>
<th>Release Introduced</th>
<th>Feature</th>
<th>Change</th>
<th>Action Required</th>
</tr>
</thead>
</table>
| 19.4.1            | Compuware Topaz 3270 Emulator                | New Feature                                 | • After an update to the 19.4.1 release, the 3270 Emulator feature must be installed. See Appendix, “Adding and Removing Topaz Workbench Features”  
• Perform a default install of Topaz Workbench or during plug-in install, select the Compuware Topaz 3270 Emulator feature. |
| 19.4.1            | Topaz for Enterprise Data                    | Packaging of the Topaz for Enterprise Data feature has been changed to include the File-AID/Eclipse, File-AID/EX, and File-AID Data Privacy features. | • Prior upgrading TED, be sure to upgrade CES to the same release level as TED.  
• After an update to the 19.4.1 release, additional plug-ins for the Topaz for Enterprise Data feature must be installed. Select either the 64-bit or 32-bit (x86) version. See Appendix, “Adding and Removing Topaz Workbench Features”  
• Perform a default install of Topaz Workbench or during plug-in install, select the appropriate Topaz for Enterprise Data feature. |
| 19.5.1            | Topaz Workbench CLI                          | Default installation path                   | • The Topaz Workbench CLI default install path location has been changed to C:\Topaz\WorkbenchCLI. This default can be changed in the install wizard during installation.  
• Previous installations of the CLI using the old default location will need to be manually deleted. An adjustment to the new path for CLI Home is required in the Jenkins Global settings under Configure System > Compuware Configurations. |

**Task 3.1 Upgrade Topaz Workbench**

Users may upgrade Topaz Workbench by using either the Update Wizard or by the reinstall method.

**Task 3.1.1 Upgrade Using the Update Wizard**

Topaz Workbench, built on Eclipse technology, offers an Update Wizard that allows users to update Topaz Workbench in place, alleviating the need to reinstall. The Update Wizard gets updates from an update repository, also known as a p2 repository.

The Update Wizard can be used to apply maintenance after an initial install of the 20.x.x release has been performed.

The following options exist for end users to upgrade via the Upgrade Wizard:

- **Obtain Updates via CES Update Center.** If you have Compuware Enterprise Services (CES) installed, CES offers a feature called Update Center that allows updates to be centrally administered, greatly simplifying the update experience for end users by alleviating the need to manually configure a p2 repository.
- **Obtain Updates from a p2 Repository.** Each user can manually configure Topaz Workbench to get updates from a p2 repository.

  If the release you are upgrading to contains new features, after performing a Check for Updates the new features must be installed. See Appendix, “Adding and Removing Topaz Workbench Features”

### Obtain Updates via CES Update Center

CES is the recommended solution for managing Topaz Workbench configuration across multiple machines within an organization. When Topaz Workbench is configured to use CES, upon startup, Topaz Workbench performs an automatic synchronization with CES to retrieve a variety of configuration settings from CES, including p2 repositories.

You can configure Topaz Workbench to use CES by specifying the CES URL in either of the following places:

- When prompted during Topaz Workbench installation.
- In the Topaz Workbench client (or an Eclipse IDE), from the Window menu, select Preferences > Compuware > Enterprise Services.

To obtain updates via CES:

1. Launch Topaz Workbench.

2. Ensure CES Synchronization has occurred. This happens automatically during Topaz Workbench startup, but can also be invoked on-demand from the Window menu, by selecting Preferences > Compuware > Enterprise Services > Sync > Finish. If your CES administrator has configured a Topaz Workbench p2 Update Site, synchronizing will automatically update your available software sites, which references the p2 update repository configured in CES.

3. Update Topaz Workbench by following these steps:
   a. From the Help menu, select Check for Updates.
   b. If there are updates available, the Available Updates dialog will display with the updates selected.

   It is important to select all of the Topaz Workbench updates so that all Topaz Workbench features are at the same version, otherwise Topaz Workbench may not function properly.

   If the release you are upgrading to contains new features, after performing a Check for Updates the new features must be installed. See Adding and Removing Topaz Workbench Features

   c. Click Next and follow the wizard instructions to completion.

   If you want to be notified when new updates are available, from the Window menu, select Preferences > Install/Update > Automatic Updates. Check Automatically find new updates and notify me to activate automatic update checking.
Obtain Updates from a p2 Repository

Compuserve provides the Topaz Workbench p2 repository from the product order email or on Compuware's support website, Compuware Support Center.

When updating the ISPW/Eclipse or the Topaz for Enterprise Data features in an Eclipse-based IDE, the following Software Sites must also be included and enabled:

- For Photon
  http://download.eclipse.org/releases/photon
  http://download.eclipse.org/eclipse/update/4.8

To update Topaz Workbench, or the plug-ins in an Eclipse IDE, from a p2 repository:

1. Download the p2 repository zip file via one of the following methods:
   - From the Topaz Workbench p2 repository link in the Topaz Workbench product order email.
   - From the Products > Topaz Workbench page under Downloads on the Compuware Support Center web site.

2. Unzip (extract) the downloaded file to a directory location.

3. Launch Topaz Workbench (or an Eclipse IDE).

4. Add the unzipped p2 repository folder as a software site.

5. From the Window menu, select Preferences > Install/Update > Available Software Sites.
   a. Click Add > Local to browse to the unzipped p2 repository folder (software site) named topazWorkbench_n.n.n.n., where n represents the release, version, maintenance level and build number.
   b. Enter a name in the Name field. Click OK.

6. From the Help menu, select Check for Updates.
   a. If there are updates available, the Available Updates dialog will display with the updates selected.
   b. Click Next and follow the Available Updates wizard instructions to completion.

It is important to select all of the Topaz Workbench updates so that all Topaz Workbench features are at the same version, otherwise Topaz Workbench may not function properly.

Task 3.1.2 Upgrade Using the Reinstall Method

This procedure uses the reinstall method to upgrade Topaz Workbench, which will vary depending on whether you are using the Topaz Workbench client or an Eclipse IDE.

Reinstall the Topaz Workbench Client

There are two options for reinstalling the Topaz Workbench:

- Install Topaz Workbench to the existing installation directory. This option is recommended as it involves fewer steps.
- Uninstall and then install Topaz Workbench:
  a. To uninstall, from the Control Panel, select Programs and Features > Topaz Workbench > Uninstall and then follow the on-screen instructions.
b. Install Topaz Workbench by following the instructions in Task 2.2.1 Install Topaz Workbench Client.

**Reinstall the Topaz Workbench Features within an Eclipse IDE**

To reinstall Topaz Workbench features within an Eclipse IDE, follow these steps:

1. Uninstall Topaz Workbench features by following the instructions in the Eclipse IDE help topic, “Uninstalling software (aka uninstalling features)“.
2. Install Topaz Workbench features by following the instructions in Task 2.2.2 Install Topaz Workbench Features into an Eclipse IDE.

**Task 3.2 Upgrade Topaz Workbench CLI on Windows**

1. Run the `setup.exe` file located in the root directory of the Topaz Workbench installation media.

   If you double-click or open the `setup.exe` and it does not execute, select the Run As Administrator option when launching `setup.exe`.

2. In the media browser, select the CLI tab.
3. Click Install Topaz Workbench CLI on Windows.
4. Once the install wizard is running, following the instructions until you reach the Choose Install Folder panel.
5. In the Where would you like to install? field, choose the folder of the existing Topaz Workbench CLI installation that is to be upgraded. A warning message appears, stating that an existing installation of Topaz CLI was found at the chosen location.
6. Select Yes to the warning message to proceed with the upgrade. By selecting Yes, the previous version of Topaz CLI will be uninstalled, then replaced with the upgraded installation to that same location.

   For Topaz for Total Test Users: Whenever you upgrade the Topaz Workbench from a previous release, always backup existing Test Projects and then update the Topaz for Total Test CLI on the Jenkins servers, including any Jenkins Build Slave servers.

**Task 3.3 Update the ISPW Connection Preference**

In Topaz Workbench release 18.2.1, a change was made to ISPW to provide a common login experience using HCI as the connection to the ISPW mainframe product. In order to function properly after upgrading from a release prior to 18.2.1, users of the ISPW feature will need to configure the ISPW connection in preferences

If you are upgrading from a release prior to 18.2.1 and have ISPW configured in Topaz Workbench, the ISPW connection needs to be reconfigured. Otherwise, skip this task and move on to Milestone 4: Configure and Verify Topaz Workbench.

1. From the Window menu, select Preferences > Compuware > ISPW > Connection.
2. Choose or configure a host where ISPW is installed.
3. Specify a runtime configuration if you want to override the default when multiple ISPW instances configured on this host.
4. Click OK and log in, if prompted.
Milestone 4: Configure and Verify Topaz Workbench

In this milestone, you will perform tasks to configure and verify core Topaz Workbench settings, such as communications, licensing, and environmental settings.

Configuration instructions related to product functionality are provided in the Topaz Workbench product help.

Role involved: Topaz Workbench Installer

Task 4.1 Configure Connection to Compuware Enterprise Services

Compuware Enterprise Services (CES) is the recommended solution for sharing Topaz Workbench configurations within an organization. By performing CES synchronization at startup, Topaz Workbench retrieves the following configuration settings from a central CES server:

- HCI host connections
- p2 update sites
- URL connections to Compuware Web products, such as iStrobe and Abend-AID

CES is required for licensing the following Topaz Workbench features: Topaz for Program Analysis, Topaz for Enterprise Data, and Topaz for Total Test. Otherwise, CES is optional.

1. Add the CES URL from the Window menu by selecting Preferences > Compuware > Enterprise Services.
2. Click Validate Connection to validate that you are connected to a compatible CES.
3. Click OK to save the CES connection.

Task 4.2 Configure Host Connections to the Mainframe

Host Communications Interface (HCI) is a component of Enterprise Common Components (ECC) and is the communications interface between Topaz Workbench and the mainframe. To communicate with HCI, Topaz Workbench must be configured with a host connection for each HCI that is configured for use with Topaz Workbench. After configuring host connections, the functions associated with the Host feature will be ready for use.

If you have CES configured in Topaz Workbench, host connections can be automatically added to Topaz Workbench when synchronizing with CES.

1. Invoke CES synchronization. Synchronization occurs automatically during Topaz Workbench startup but can also be invoked on-demand from the Window menu by selecting...
Preferences > Compuware > Enterprise Services > Sync > Finish. If your CES administrator has configured host connections, synchronizing will display a list of host connections.

2. Check the host connections that would like to synchronize and they will be added/updated in your instance of Topaz Workbench.

If you do not have CES configured, you can configure host connections manually:

1. Open Topaz Workbench to the Host Explorer view.
2. Right-click Hosts. Click Configure, then click Add.
3. Configure a host connection by entering description, host, port, and optionally, an encryption protocol. Topaz Workbench performs connection validation when you click OK to save these settings.

Task 4.2.1 Verify Connection to the Mainframe

To verify that you can connect to the mainframe with a given host connection:

1. Open the Host Explorer view.
2. Expand the Hosts tree node, right-click on the configured host, and select Login.
3. A successful login indicates that the host connection is working properly.

Task 4.3 Verify Topaz for Total Test

To verify that Topaz for Total Test is licensed for use:

1. In Topaz Workbench, from the Help menu, select Topaz Workbench licensing.
2. If the Topaz for Total Test feature pack is displayed, select the Topaz for Total Test feature pack and select Check Out. If the license check out succeeded, the Lease Begin and Lease End dates will be updated.

Refer to the Topaz Workbench Topaz for Total Test User Guide in the Topaz Workbench online help for more information on configuring Topaz for Total Test and using sample COBOL programs for generating and running unit tests.

Task 4.4 Verify Topaz for Program Analysis

To verify that Topaz for Program Analysis is licensed for use:

1. In Topaz Workbench, from the Help menu, select Topaz Workbench licensing.
2. If the Topaz for Program Analysis feature pack is displayed, select the Topaz for Program Analysis feature pack and select Check Out. If the license check out succeeded, the Lease Begin and Lease End dates will be updated.

Task 4.5 Configure and Verify Topaz for Enterprise Data

Task 4.5.1 Configure Topaz for Enterprise Data

For license checking, Compuware Enterprise Services (CES) is required. Configure the Topaz Enterprise Data components to identify the CES location. For use with Data Privacy:

1. Identify the location of File-AID Services in the Topaz Workbench Preferences.
2. Configure File-AID Services to identify the location of CES.
3. Configure each File-AID Execution Server to identify the location of File-AID Services.
4. The File-AID Rules Engine must be installed with each File-AID Execution Server. This includes the Embedded Execution Server installed with Topaz Workbench and the Standalone Execution Servers installed for Topaz Enterprise Data.
5. Configure the Standalone Execution Servers to identify the location of CES. There are two configuration options available.
   - The default configuration is to get the location of CES from File-AID Services. This option can be used by existing customers who already have File-AID Services installed and running. It provides a centralized management of the CES definition.
   - The location of CES can be configured directly in the Execution Server by editing the Execution Server properties file to include the location of CES. This option can be used by existing File-AID/EX customers who are not using Data Privacy.

**Task 4.5.2 Verify Topaz for Enterprise Data**

**A. Verify connectivity to File-AID mainframe products**

1. Open the Host Explorer view.
2. Expand the **Hosts** tree node, right-click on the host where File-AID is installed and select **Login**.
3. After successful login, open the **Console** view and review the messages to verify that the expected File-AID mainframe components are installed. For example:
   - File-AID Common Components Version 17.02.00 API Level 17.02.02 is Installed
   - File-AID for DB2 Version 17.02.00 API Level 17.02.00 is Installed
   - File-AID/MVS Version 17.02.00 API Level 17.02.02 is Installed
   - File-AID for IMS Version 17.02.00 API Level 18.02.01 is Installed
   - File-AID/RDX Version 17.02.00 API LEVEL 17.02.00 is Installed

**B. Verify that Topaz for Enterprise Data is licensed for use**

1. In Topaz Workbench, from the **Help** menu, select **Topaz Workbench licensing**.
2. If the Topaz for Enterprise Data feature pack is displayed, select the Topaz for Enterprise Data feature pack and select **Check Out**. If the license check-out succeeded, the **Lease Begin** and **Lease End** dates will be updated.

**Task 4.6 Configure Topaz Connect**

Follow these steps to configure and verify Topaz Connect to connect to a CA Endevor instance. You must be authorized to use CA Endevor to perform these steps.

**Task 4.6.1 Configure Topaz Connect**

1. From the **Topaz Connect** menu, select **Connection**.
2. Configure the Topaz Connect connection by entering the following:
   a. In the **Host** and **Port** fields, enter the Topaz Connect IP address and port.
   b. If using Application Transparent Transport Layer Security (AT-TLS), select the **TLS Enabled** check box.
   c. In the **User Name** and **Password** fields, enter your TSO ID and password.
   d. Click **Finish**.
3. From the **Topaz Connect** menu, select **Endevor Options Configuration**.
4. In the **Client Path** field, enter or browse to the full path to be used as a working directory.
5. Click **Finish**.

**Task 4.6.2 Verify Topaz Connect**

To verify Topaz Connect is configured to connect to the mainframe and access Endevor elements, perform these steps.
1. From the Topaz Connect menu, select Endevor Elements. Select each of the following filter buttons to populate the filter criteria: Environment Filter, Stage Filter, System Filter, Subsystem Filter, and Type Filter.
2. Select a value from each of the filter lists.
3. Enter a pattern in the Element Filter field. Use an asterisk as a wildcard character.
4. From the Foreground/Batch, select Foreground.
5. Click Finish. If an Endevor Element browse view is opened and displays Endevor elements, Topaz Connect verification is complete.

Task 4.7 Configure Xpediter/Eclipse

Xpediter/Eclipse provides Eclipse cheat sheets to guide you through starting a debug session, which will suffice for verifying the Xpediter/Eclipse configuration.

Task 4.7.1 Verify Xpediter/Eclipse is Configured for Debugging a CICS Program

If Xpediter/CICS has been installed and configured, follow these steps to verify that Xpediter/Eclipse can debug a CICS program.

1. From the Help menu, select Cheat Sheets > Compuware > Xpediter/Eclipse > Create an Xpediter CICS debug configuration.
2. Follow the instructions in the cheat sheet. In the step, Specify Program to Debug, enter CWDEMCB2, which is the Xpediter/CICS sample COBOL program. Once the debug session is started successfully, verification is complete.

Task 4.7.2 Verify Xpediter/Eclipse is Configured for Debugging a Batch Program

If Xpediter/TSO has been installed and configured, follow these steps to verify that Xpediter/Eclipse can debug a batch program.

1. From the Help menu, select Cheat Sheets > Compuware > Xpediter/Eclipse > Create an Xpediter batch debug configuration.
2. Follow the instructions in the cheat sheet.
   - In the step, Specify Batch Job Location, enter the Xpediter/TSO sample JCL to run the sample COBOL program TRIMAIN. The sample JCL can be found in hlq.SLXTSAMP(TRIJCL), where hlq is your high-level qualifier of the Xpediter/TSO sample library as specified by your Xpediter/TSO administrator.
   - In the step, Specify Load Libraries, you may need to add the load library that TRIMAIN was compiled into unless the Xpediter/TSO administrator added the load library to the sample JCL. Once the debug session is started successfully, verification is complete.

Task 4.8 Configure ISPW

To configure ISPW:

From the Window menu, select Preferences > Compuware > ISPW > Connection. Choose or configure a host where ISPW is installed. Specify a runtime configuration if you want to override the default when multiple ISPW instances are configured on this host. Click OK. Log in, if prompted.

To verify configuration:

Open the ISPW Repository Explorer view. If the Streams and Applications lists contain values, then the ISPW Eclipse feature has been configured properly.
Task 4.9 Configure Abend-AID

Abend-AID server definitions can be populated by CES Synchronization or manually from the Window menu by selecting Preferences > Compuware > Abend-AID.

To verify the configuration, from the Compuware menu, select Abend-AID and select a host value. The display of the Abend-AID logon screen in Abend-AID view confirms the configuration.

Task 4.10 Configure iStrobe

iStrobe server definitions can be populated by CES Synchronization or manually from the Window menu by selecting Preferences > Compuware > iStrobe.

Verify the iStrobe configuration from the Compuware menu by selecting iStrobe > server. The display of the iStrobe logon screen in the iStrobe view confirms the integration.

Task 4.11 Configure Topaz 3270 Emulator

The Topaz 3270 Emulator connection settings can be populated by CES Synchronization or manually from the Window menu by selecting Preferences > Compuware > Topaz 3270 Emulator. Under Host, specify the mainframe Hostname and Port that will be used during connection. Adjust the other settings as necessary.

VERIFY the Topaz 3270 Emulator configuration by clicking on the Topaz 3270 Emulator icon in the main taskbar. A window should open displaying the VTAM screen.
Milestone 5: Deploy Topaz Workbench

This milestone covers topics related to deploying Topaz Workbench to multiple end users. Prior to deployment, you have the option to configure Topaz Workbench so that it is ready for use by end-users upon deployment.

Configuration Settings

Task 5.1 Configure Topaz Workbench for End Users

If you would like to configure settings for your end users so that Topaz Workbench is ready for use upon deployment, follow these tasks.

Task 5.1.1 Create Centrally-stored Configurations for Automatic Synchronization

Role involved: CES Administrator

If your site uses Compuware Enterprise Services (CES), Compuware recommends configuring some essential Topaz Workbench settings in CES. The configuration settings are automatically available to end users upon connecting to CES through Topaz Workbench. These settings include the following:

- Mainframe host connections
- A repository for updating Topaz Workbench software

Your CES Administrator can follow the instructions in the CES product help to configure host connections and the Update Center. Once configured, Topaz Workbench users can access the mainframe through the host connections made available via CES. Topaz users will also be able to update their Topaz Workbench software from the Help menu by selecting Check for Updates.

Task 5.1.2 Configure Topaz Workbench for First-time Users

Role involved: Topaz Workbench Installer

1. Topaz Workbench administrator configures Topaz Workbench as desired.
2. Exit Topaz Workbench.
3. Copy the \workspace folder to a location where the deployment scripts can access them.
4. In your deployment script, after the product is installed, add commands to copy the \workspace folder to \Users\<UserProfileName>\Compuware. This is the default workspace location for the given user. When the user starts Topaz Workbench, the configuration settings will be ready for use, thus minimizing manual configuration for that user.
Task 5.2 Deploy Topaz Workbench to End Users

Role involved: Topaz Workbench Installer

Topaz Workbench offers a silent install as a method of deploying to multiple end users. Silent install is a command line install with no user interface. Deployment tools, such as System Center Configuration Manager (SCCM), can be used to run the silent install on multiple workstations.

The process for installing or upgrading end users via silent install involves the following:

1. Run the install, recording all inputs to a response file. A response file is important for customizing the install options and location to be installed.
2. Edit the response file for customization.
3. Create a script to do the following:
   a. For first-time users, install Topaz Workbench. Optionally, you can then copy an initialized, configured workspace to the users’ workstation. See Task 5.1.2 Configure Topaz Workbench for First-time Users.
   b. For existing users, upgrade Topaz Workbench.

Compuware recommends that you install Topaz Workbench to a location that users have rights to update, such as the user’s home directory (for example, C:\Users\JaneDoe\Compuware\Topaz). Window’s Program Files folder is often restricted and prevents users from updating Eclipse-based software.

Task 5.2.1 Record and Customize a Silent Install Response File

The program for installing Topaz Workbench is located on the installation media at \cpwr\Topaz\Windows\Disk1\InstData\VM\install.exe

To run the installation and record a response file, execute the following command,

```
install.exe -r <response_file_path>
```

where `<response_file_path>` is the directory where the response file will be placed. For example, if the Topaz Workbench media has been copied to C:\media and a directory exists at C:\silent, then the following command will perform a silent install and create a response file.

```
C:\media\cpwr\Topaz\Windows\Disk1\InstData\VM\install.exe -r C:\silent
```

For deployment to end users, the response file can be edited to change the target install and workspace directories, if desired.

To change the target install directory, change the value assigned to USER_INSTALL_DIR in the installer.properties file. For our example, this file is in the C:\silent directory.

For example,

```
USER_INSTALL_DIR=$prop.user.home$\Compuware\Topaz
```

To designate a default Topaz Workbench workspace directory, add the WORKSPACE_DIR parameter to the installer.properties file and give it a value for the desired default directory path.

1. $prop. is an InstallAnywhere variable that can access any Java property. In this example, $prop.user.home$ returns the value of the user.home property — the user’s home directory.
For example,

```java
WORKSPACE_DIR=\@user.home\Compuware\Workbench\workspace
```

Use a **double-backslash** to specify the directory paths in the parameter values. Use a **backslash** to escape the colon (:) when specifying a drive letter for Windows.

For example: WORKSPACE_DIR=C:\\myhomedirectory\\Compuware\\Workbench\\workspace

### Task 5.2.2 Create a Deployment Script to Install Topaz Workbench for First-Time Users

Users who are new to Topaz Workbench will not have Topaz Workbench installed. Therefore, the only necessary command is to run the install silently. First-time users may benefit from a pre-configured product as well. The steps below outline both options.

1. Create a script file, such as a Windows batch file (.bat), that can be used by your deployment tool.
2. Edit the script file with the following commands to deploy the product for first-time users via a silent install.
3. Optionally, copy a configured workspace to the users’ default workspace location.
4. Use a deployment tool to run the script on the machine of each new Topaz Workbench user.

The command to copy the workspace should only be done for first-time users. If a user has been using Topaz Workbench, this will overwrite their workspace data.

**Example**

Here is an example of the commands to perform a silent install copy an initial workspace:

```bash
C:\media\cpwr\Topaz\Windows\Disk1\InstData\VM\install.exe -i silent -f
C:silent\installer.properties
xcopy X:\workspace %USERPROFILE%\Compuware\Workbench
```

### Task 5.2.3 Create a Deployment Script to Upgrade Topaz Workbench for Existing Users

The section contains instructions for upgrading Topaz Workbench interactively. Alternatively, you can use silent install to upgrade Topaz Workbench by uninstalling and reinstalling.

To upgrade Topaz Workbench silently, follow these steps:

1. Create a script file, such as a Windows *\.bat* file, that can be used by your deployment tool.
2. Edit the script file with the following commands to uninstall and reinstall the product for existing Topaz Workbench users via a silent install.

**Example**

Here is an example of the commands to perform a silent uninstall followed by a silent install of Topaz Workbench:

```bash
%USERPROFILE%\Compuware\Topaz\uninstall\uninstall.exe -i silent
```

---

1. `@user.home` resolves to the user’s home directory by the Java Virtual Machine (JVM).
C:\media\cpwr\Topaz\Windows\Disk1\InstData\VM\install.exe -i silent -f C:silent\installer.properties

It is advisable to run the script from a directory that is outside the install folder directory structure since it could prevent the uninstall from occurring.

Sharing Configuration Settings

After Topaz Workbench has been installed, users may find a need to share their configuration settings with other members of the team or even across the organization. Certain configuration settings can be imported and exported using the traditional method (described in Task 5.2.5); or a more complete set of Topaz assets can be shared using the recommended Team Profiles method.

Task 5.2.4 Using Team Profiles to share Topaz Workbench Configuration Settings

Roles involved: End-users

Topaz Team Profile provides an easy and recommended way to share Topaz assets among users to speed up the adoption of Topaz across an organization. Topaz Team Profile allows a user to export assets either to Compuware Enterprise Services (CES) or to a file and, subsequently, other users can import those same assets or a subset of those assets to their Topaz instance. These assets include the following:

- Configurations, such as launch configurations, Data Editor requests, search and compare requests.
- Projects, including both Compuware-specific projects (mainframe, Topaz for Total Test, ISPW) and non-Compuware specific projects.
- Preferences, meaning any setting set via the Preferences dialog box.
- Working sets of all types.

For more information and steps involved in creating, importing, and exporting Team Profiles, see the Host Explorer User Guide found in the Topaz Workbench online help.

Task 5.2.5 Export/Import Topaz Workbench Configuration Settings (Legacy Method)

Roles involved: End-users

Use the following Legacy method if you do not wish to use the recommended Team Profiles to distribute configuration settings described in Task 5.2.4.
To export Compuware-specific configuration settings:

1. From the File menu, select Export > Compuware > Compuware Legacy Export > Compuware Configuration Settings and export the desired configuration settings to a directory.

2. To export debug configurations used by Xpediter/Eclipse, from the File menu, select Export > Run/Debug > Launch Configurations. Click Next. Choose the launch configuration files to export to a file system location.

To import Compuware-specific configuration settings:

1. From the File menu, select Import > Compuware > Compuware Legacy Import > Compuware Configuration Settings and specify the directory containing the exported settings and import the configuration settings.

2. To import debug configurations used by Xpediter/Eclipse, from the File menu, select Import > Run/Debug > Launch Configurations. Browse to the directory containing the exported launch configurations. Choose the launch configurations to import.
Troubleshooting

For each error message listed below, possible causes and suggested corrections are provided.

 Updating Message

‘Updating Software’ has encountered a problem.
An error occurred while uninstalling
Backup of file C:\Program Files\Compuware\Topaz Workbench\eclipse\META-INF\MANIFEST.MF
failed.
File that was copied to backup could not be deleted

Possible causes:
– The user does not have sufficient privileges to make changes to the installation directory
during a p2 update.

Suggested corrections:
– Give the user full control of installation directory.
– Reinstall to a directory outside of Program Files.
– Upgrade to the most recent version of Topaz Workbench.

 Dependency Message

Cannot complete the install because of a conflicting dependency

Possible causes:
– The user does not have sufficient privileges to make changes to the installation directory
during a p2 update.
– The version being upgraded to is not compatible with a p2repo update.

Suggested corrections:
– Give the user full control of installation directory.
– Reinstall to a directory outside of Program Files.
– Upgrade to the most recent version of Topaz Workbench.

 Version Check Messages

Invalid Response to Version Check (Return Code 789)

Possible causes:
– JCL error. The return code 789 means the CSS TP was unable to obtain the version check
information.

Suggested corrections:
– The STASK statement in the HCI parmlib member (default HCI00) is not specified, or it
specifies the wrong PROC name.
– The PROC does not exist in a PROCLIB scanned by the system.
– The PROC has JCL errors and will not start.
– The STEPLIB DD of the PROC is not set up with the proper HCI, CSS, and File-AID libraries.
– The STEPLIB DD libraries are not APF-authorized.
– Security issues caused the PROC not to start. All datasets defined in this PROC (STEPLIB) must either have (a) universal read access (UACC READ) or (b) the PROC must be defined to a started-task security group that has READ access to all of these datasets.
– If there are no Data Editor/File-AID functions to be used, such as iStrobe only plug-in installed, this message is displayed as a warning message ‘only’ meaning Data Editor is not accessible.
– If the CXSS* Started Task PROC was updated, to make changes to the Proc, HCI must be recycled.

Please contact your mainframe administrator or Compuware Technical Support. There is a Mainframe configuration issue with either HCI or File-AID Common (VJ). RC=789. Reason=Unable to obtain version check information. A timer has expired while waiting for it to be returned. The version check started task was initiated, but HCI has never heard back from it (causes: authorization issues in started-task, started-task JCL error, no proc defined in PROCLIB).

Possible causes and correction:
– For AFC2 users, the CXSSTC started task ID needs to have a GSO definition in the STC table to allow it to start jobs with a dynamic name.

Silent Install Message

NullPointerException during silent install

Possible causes:
– The installation directory structure was not preserved when copied from the install media.

Suggested corrections:
– Re-copy the installation setup program, preserving the parent directory structure \Topaz\Windows\Disk1\InstData\VM
Appendix A.
Topaz Workbench Licensing

Topaz Workbench features are licensed using one of three Compuware licensing mechanisms:

Table 1. Compuware License Providers

<table>
<thead>
<tr>
<th>Feature</th>
<th>Licensing Mechanism</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Topaz Workbench base features</td>
<td>License Management System (LMS)</td>
<td>Hosted on the mainframe. Host Explorer requires at least one Compuware mainframe product license. All other features interface with a Compuware mainframe product, requiring that product to be licensed.</td>
</tr>
<tr>
<td>Topaz features</td>
<td>Options:</td>
<td>Licenses are leased for a defined time period. Refer to Leased Licensing for more information.</td>
</tr>
<tr>
<td></td>
<td>• Topaz for Program Analysis</td>
<td>Options: On-premise via Compuware Enterprise Services (CES)</td>
</tr>
<tr>
<td></td>
<td>• Topaz for Enterprise Data</td>
<td>Options: Cloud hosted by Compuware</td>
</tr>
<tr>
<td></td>
<td>• Topaz for Total Test</td>
<td></td>
</tr>
<tr>
<td>File-AID/EX</td>
<td>Distributed License Management</td>
<td>Distributed client or server based licensing.</td>
</tr>
</tbody>
</table>

Leased Licensing

The following Topaz Workbench features use leased licenses that expire after a certain period:

- Topaz for Program Analysis
- Topaz for Enterprise Data
- Topaz for Total Test

Licensing of these features can be done through Compuware's cloud licensing or on-premise using CES. If you are interested in leveraging Compuware's cloud licensing service for Topaz Workbench's licensed features, contact your Compuware sales representative or contact Compuware support at Compuware Support Center. If you want to use on-premise licensing through CES, configure the connection to CES by following the instructions in Configure Connection to Compuware Enterprise Services.
Appendix B.
Uninstall Topaz Workbench

This appendix contains instructions on uninstalling Topaz Workbench using a silent install. To uninstall interactively, follow these instructions.

Task B.1 Uninstall Topaz Workbench

Method 1:
1. From the Control Panel, select Programs and Features > Topaz Workbench.
2. Click Uninstall and follow the on-screen instructions.

Method 2:
Execute the uninstall.exe program in the uninstall folder located in the folder where you installed Topaz Workbench.

Method 3:
Delete the directory where you installed Topaz Workbench.

If you uninstalled Topaz Workbench using Method 3, and plan to reinstall Topaz Workbench using SCCM, then the following registry key must be deleted prior to attempting the reinstall.

HKLM\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Topaz Workbench

Task B.2 Uninstall Topaz Workbench CLI on Windows

1. From the Control Panel, select Programs and Features > Topaz Workbench CLI.
2. Click Uninstall and follow the on-screen instructions.

Alternatively, you can execute the uninstall.exe program in the uninstall directory where you installed Topaz Workbench Command Line Interface (CLI).

Task B.3 Uninstall Topaz Workbench CLI on Linux

Run ./uninstall from the uninstall folder where Topaz CLI was installed.
Appendix C.
Adding and Removing Topaz Workbench Features

This appendix contains the instructions to add or remove features from Topaz Workbench.

Task C.1 Adding Features to Topaz Workbench

To install additional Topaz Workbench features into an existing installation of Topaz Workbench or an Eclipse IDE:

1. Download the p2 repository zip file using one of the following methods:
   - From the Topaz Workbench p2 repository link in the Topaz Workbench product order email.
   - From the Products > Topaz Workbench page under Downloads on the Compuware Support Center web site.

2. Unzip (extract) the downloaded file to a directory location.

3. Within existing install, from the Help menu, select Install New Software to add a software site.
   a. Click Add > Local to browse to the unzipped p2 repository folder (software site), named topazWorkbench_n.n.n.n, where n represents release, version, maintenance level and build number.
   b. Provide a name in the Name field. Click OK.

4. Select the desired features to install. Click Next and follow the instructions to complete the install wizard.

5. Click Next and follow the install wizard instructions to completion.

The release of the p2 repository used to add features must be the same as the Topaz Workbench release to which they are being installed.

Task C.2 Remove Individual Topaz Workbench Features

To remove individual Topaz Workbench features:

1. From the Help menu, select About > Installation Details > Installed Software.

2. Select the feature to uninstall and click Uninstall.

3. Follow the Uninstall wizard instructions to completion.
Checklist of Milestones and Tasks

- **Milestone 1: Prerequisites**
  - Task 1.1 Verify System Requirements
  - Task 1.2 Verify Compuware Companion Product Requirements
    - Task 1.2.1 Ensure ECC is configured for use with Topaz Workbench
    - Task 1.2.2 Ensure CES is configured for use with Topaz Workbench
    - Task 1.2.3 Ensure additional Compuware companion products are installed and configured for use with Topaz Workbench

- **Milestone 2: Install Topaz Workbench**
  - Task 2.1 Determine Topaz Workbench Features to Install
  - Task 2.2 Install Topaz Workbench
    - Task 2.2.1 Install Topaz Workbench Client
    - Task 2.2.2 Install Topaz Workbench Features into an Eclipse IDE
  - Task 2.3 Install Topaz Workbench CLI
    - Task 2.3.1 Install Topaz Workbench CLI on Windows
    - Task 2.3.2 Install Topaz Workbench CLI on Linux

- **Milestone 3: Upgrade Topaz Workbench**
  - Task 3.1 Upgrade Topaz Workbench
    - Task 3.1.1 Upgrade Using the Update Wizard
    - Task 3.1.2 Upgrade Using the Reinstall Method
  - Task 3.2 Upgrade Topaz Workbench CLI on Windows
  - Task 3.3 Update the ISPW Connection Preference

- **Milestone 4: Configure and Verify Topaz Workbench**
  - Task 4.1 Configure Connection to Compuware Enterprise Services
  - Task 4.2 Configure Host Connections to the Mainframe
    - Task 4.2.1 Verify Connection to the Mainframe
  - Task 4.3 Verify Topaz for Total Test
  - Task 4.4 Verify Topaz for Program Analysis
  - Task 4.5 Configure and Verify Topaz for Enterprise Data
    - Task 4.5.1 Configure Topaz for Enterprise Data
    - Task 4.5.2 Verify Topaz for Enterprise Data
- **Task 4.6 Configure Topaz Connect**
  - Task 4.6.1 Configure Topaz Connect
  - Task 4.6.2 Verify Topaz Connect

- **Task 4.7 Configure Xpediter/Eclipse**
  - Task 4.7.1 Verify Xpediter/Eclipse is Configured for Debugging a CICS Program
  - Task 4.7.2 Verify Xpediter/Eclipse is Configured for Debugging a Batch Program

- **Task 4.8 Configure ISPW**

- **Task 4.9 Configure Abend-AID**

- **Task 4.10 Configure iStrobe**

- **Task 4.11 Configure Topaz 3270 Emulator**

- **Milestone 5: Deploy Topaz Workbench**

  - **Task 5.1 Configure Topaz Workbench for End Users**
    - Task 5.1.1 Create Centrally-stored Configurations for Automatic Synchronization
    - Task 5.1.2 Configure Topaz Workbench for First-time Users

  - **Task 5.2 Deploy Topaz Workbench to End Users**
    - Task 5.2.1 Record and Customize a Silent Install Response File
    - Task 5.2.2 Create a Deployment Script to Install Topaz Workbench for First-Time Users
    - Task 5.2.3 Create a Deployment Script to Upgrade Topaz Workbench for Existing Users
    - Task 5.2.4 Using Team Profiles to share Topaz Workbench Configuration Settings
    - Task 5.2.5 Export/Import Topaz Workbench Configuration Settings (Legacy Method)